6432 Controller does not start homing after power up

I have upgraded my K40 Laser with your Ruida 6432 set and so far all is fine except the homing after the startup of the system. I have configured the x and y axis and enabled homing but I always have to go to the Menu and have to select reset x/y axis manually after each power on. This is a littlebit annoying and not as expected. Do you have a solution for this issue?

Hi Cornelius,
If you have connected the controller to the computer,please adjust the following options to ‘YES’;If you have not connected the controller to the computer,please ensure that you have completed the following options:
1.Press [Menu] in the main interface,and you will see the pop-up menu interface.
2.Open the ‘Axes Reset+’ and check the x, y axis to reset automatically.

If none of the above methods work, please try to restore factory settings.‘Set Default Para’–‘Input the password HF8888’.

If you have any questions, please contact us.

Thanks for the hints, but unfortunately nothing have worked and the RD 6432 has a different Menu as you described. I have attached the settings and the Menu items. I think it is a firmware Problem. Can you please evaluate it on your side? The manual homing via „Menu“->“Function set“->“Axes reset“ does work, but not the automatic homing after power on




Hi Cornelius,
Sorry for the late reply.As for your problem,we advice you to solve that as the following steps:
1.connect the mainboard to the software RDworks V8
2.read the parameters


and the auto home X and atuo home Y should be ‘No’
3.Modify the auto home X and the auto home Y from ‘No’ to ‘Yes’

then click the ‘Write’

Many thanks for your feedback but unfortunately I have done this already and again: after power on of the machine and controller, it does not start the homing. I always have to trigger the homing manually have you tried it on your side with a machine with the 6432g controller? This controller was part of the K40 upgrade package which I have ordered on your shop

Hi Cornelius,
It’s our pleasure to help you solve the problem.
Do you have RDworks software? This board of ours can not only use the board to set the automatic reset at power-on. It can only be connected to the software and write the automatic reset program into the board according to the above method.

I have checked it again and write the values as you proposed via RDWorks to the controller but it does not start homing after power on. I have tried also to write the controller settings via Lightburn but it is always the same result: It does not home on startup and I have to do it manually via the controller menu or via lightburn or RDWorks. This is really annoying and I can not imagine that it really does work on your side. Do you have any further suggestions? Can you please try it by your own on a real 6432 controller and not on a better/bigger one?

Hi Cornelius,
I have used a RDC6432 to do the test,and it can reset automatically.Please operation as the following steps:
1.According to the method I said above, set the automatic reset option of x and y axis form NO to YES and read the parameters。
2.File–Vendor settings–input the password’RD8888’,then you’ll see the interface like this:


3.Select X axis,read the parameters,check the ‘Enable HOME’,finally write the parameters.Then the setting of y axis is similar to x axis.

We hope this way will be useful for you~

Many thanks for your test again. Unfortunately I have done the exact procedure as you have described it several times. So i think I have a different firmware version or a brocken Controller. So maybe you can give me a last advice: which firmware version do you use? And can you give me a download link for that firmware. If this doesn’t work, I have to return the controller as a warranty case.

My firmware version is: RDC-V27.01.05
HMI: 16.00.04

Many thanks in advance for your good support on that case!

Hi Cornelius,
I’m sorry that my version is the same to you,that may some problems with your main board.You can contact me by the Whatsapp,my account number is +86 18362090090 if you have any other problems.
Regards

Many thanks to the superb support on that issue. After all it was an old RDWorks SW. After updating RDWorks to the newest version and the configuration described above, the automatic homing after power up does work now.

RDWorks version:
http://www.rd-acs.com/newsinfo/1078010.html?templateId=643416

Configuration Settings (user settings, not vendor settings):