No marking QS P 50

Have a return problem, everything appears to be working okay, but when it comes to actually marking it goes through the motions but with no real power. Had this problem when I got the laser, and just uninstalled and reinstalled everything and it worked. This time it hasn’t. It’s focused, all parameters are fine, Help!

Sorry I’m no help, but I have the same exact issue. Haven’t had any respond from their team to assist with this.

I did get a reply from them the first time it happended, but I got it working before they replied, but what ever I did, isn’t working now???

I’m troubleshooting with their tech on Friday I just confirmed. If we figure something out, I will fill you in.

settings ? Focus ? Laser parameter settings ? Could be anything from the limited info you have posted.Need more information.

Lens f420, focus at 410, speed 500, pwr 50% Freq 25, Q pulse 25.
Uninstalled and re installed, more than once, (it did work once after I done that before) Had it run continuous, adjusted focus bottom to top, but back to no marking and I’m at a loss as to why

Update, after sending numerous messages, emails and recieving some pretty useless replys, I’ve sent pictures and videos of the inside of the machine, multimeter readouts, and even a thermometer to show shop temprature, one of the solutions was to warm it up with a hairdryer! FFS. Still no closer to getting the bloody thing fixed! Gone from mildly annoyed, through pissed off and rapidly approaching very angry :angry:

I’m in the same boat and no reply as well. I’ve even gone to the FB group and nothing. Time to cut loses and go with a better bender.

If you purchased the machine from the official Cloudray website (, then contact the official and you will get a reply. If you purchased your machine elsewhere, no official support will be provided.

Sorry to make you go through so long, the after-sales team has been following up and assisting you to solve the problem, please cooperate with Cloudray team to troubleshoot in time. cloudray official will also discuss the compensation plan with you after the problem is solved. Thanks in advance.

Please send information to email:

Hi. I have exactly the same machine with the same setup and the same problem as KevCollyer. I also purchased the laser through On the 9th of April I told cloudray about my problem but I haven’t received a reply yet.

Hi Micheal, I have had responce from support via email and Whatsapp, and I am hoping, sometime today will have a tech run diagnostics remotely via some app they sent me. I don’t know if this will fix it, but willing to try anything, and keep going till its resolved! The trouble is China is 8 hours ahead of me here in UK, so everything takes too long!!
I’ll update you as things progress
Take care
Kev C

Kevin J Collyer

That would be nice. A big thanks from Germany.

Hi Micheal, update I had a remote session with the tech from china this morning and happy to say my machine is now working. Not sure exactly what the problem was but it was fixable via remote!
Now a happy bunny.
Kind regards

Kevin J Collyer

Hi Kevin,

thank you for sharing your experience. Support contacted me today. let’s see if we can solve the problem.


I had the same problem and found it was the Q pulse setting was too low. My machine started with a setting of 20ms but it needed to be around 150ms to really work well. I was watching some of Cloudrays videos of the machine and at the right time I could pause the video and see their screen/settings. One video had a setting of 150ms while another had 200 ms. After talking through email with customer support they confirmed the setting should be higher. Hope that helps! Now the engraver cuts! and engraves very well with more than enough power! Later after engraving some Aluminum I set the Q-pulse back to 20 again to engrave through a painted ink on the aluminum surface. Adjust as you need.

Set Q pulse to 150 or at least 100