Help! New Laser mark control board v4 cannot verify digital signagture


I recently purchased a new 50W Cloud Ray Fiber Laser and followed the install instructions.

I may have accidentally installed the drivers the first time without the Laser Machine powered on. I have since deleted all the info and drivers and re-installed everything when everything was on but I keep getting several error messages.

  1. Laser Mark Control Board V4 (Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)

  2. When I open Ezcad2 it’s stuck in Demo mode. I’m assuming because the Laser Mark is not recognizing the signature.

I’ve tried uninstalling and reinstalling the program several times now and keep getting the same message.

Does anyone have any ideas? I am new to Laser machines and have never used the machine or software before and am lost.

Thank you,


Hi Jere, please provide your order number and the nameplate of the machine.

1 Like

Order #12704.

Please disregard this. I tried some other methods to get it to work and got it working!

Thank you!

Glad the machine is back to normal. If you have any further questions, you can contact us anytime.

1 Like

Hi Jeremygsu,

please expand on how you solved this issue? I have been running my 60w for a few weeks now from my desktop, and I am now attempting to setup a laptop and I am running into the same Driver issue. Thank you!

im having the same issues please post

This is what has been working for me.

Hold down shift and restart the computer.

Click on Troubleshoot, then Advanced Options, then Start Up Settings. Then F7.

The computer will restart itself and my program loads correctly after that. Once and awhile I’ll restart my computer regularly and then have to go through the F7 step again to get it to work, otherwise it’s in demo mode.