Laser will not connect to Lightburn or EZCAD

Machine purchased directly from Cloudray - Order ID 20393

MP60 Mopa laser will not connect to PC (either with Lightburn or EZCAD). It has been working correctly for several months, issue started this morning. No updates or changes have been made to the OS, software or drivers. I’ve tried reinstalling both drivers to no avail. In lightburn, when starting up it toggles between FRAMING and DISCONNECTED repeatedly. When I uninstall the lightburn driver and try to use EZCAD it freezes for a bit and then says FAILED TO INSTALL IMC Driver.

I have tried reinstalling the software and have switched out the USB cable. Neither will fix the issue. Drivers are not showing any issues in Device Manager. Windows 10 OS.

Both EZCAD and Lightburn have functioned correctly since I purchased and installed the machine. Any idea on what the issue may be?

Ezcad and lightburn can be used on the same computer, you just need to change the driver.
Have you checked that you have the correct driver installed?

Did your issue get resolved? I am having the exact same issue. I have a very expensive boat anchor right now.

Do you see the board signature in the device manager?

Lightburn can’t connect if the os can’t see the device in the device manager… Don’t know about EZCad… I have Linux.

Good luck