Cloudray Lift Metal Parts Step Length Problems

Hi, I just installed the Cloudray Lift Kit in my Red and Black 100w laser. I have shorter ball screws than came with the kit and made my own brackets.
The problem I’m having is the Distance Per Pulse or Step Length in RDWorks.

To even get the motor to move I have to set it to 29 um an above. Anything lower and it stalls.
When I try to calibrate it I get a Step Length that is way lower, like in the 7.?? range and the motor stalls.

I have the stepper driver set like the video that MW Laser made with the current at 5.83A and 400 Steps/rev.
With ON written on the dip switch I have 1 on, 2&3 off, 4 maybe on or off, I tried them both and 5-8 on. I haven’t changed any of the jumpers inside the driver.

As far as wiring I tried the setup in the video and other suggestions and found that wiring them in the same way in parallel with no A or B swapping worked just fine.

I even put in a 36v dc power supply thinking that 24 volts might be too low but having the same problem.

It’s just the Step Length I’m having a problem with.
I have a Ruida RDC6442S Controller.

Do you have any Ideas on what might be wrong?

Any Help would be most appreciated.



Panel jog setting 100, press Z- to see how much the z-axis has dropped, measure it out and fill in to calculate the motor step distance
Measure the length.

File–Vendor Settings–Input the password’RD8888‘,then click the”…" behind the Step length.

Hi, thanks for replying.

I’ve done that several times to Calculate Step Precision. I always get a number lower than 10.
The steppers won’t work, they just make bad noises. Unless the Step Length is 29um or higher the steppers won’t move.



Hi JefferyS,
you can see a table of subdivision and pulse number is posted on the back of the drive. Please dial the dial code to set the corresponding subdivision and pulse number according to your needs.

Hi, I’ve tried many 400, 800, 1600. I can always find a number to make it move but when I calibrate it and enter the Step Length it always stalls.

As far as current I’ve tried the bottom three settings and it made no difference.